
Reveal the mystery of the mask 
Imagine you're participating in a group brainstorming session to generate new ideas for 
the design phase of a new project. The facilitator starts the brainstorming session with the 
word "mask" and instructs the group to make a list of words or phrases relating to mask. 
From the list, the group creates a definition for the word with subtopics. These include 
the definition, processes, and word associations.  

One definition of mask is a cover or partial cover to protect or conceal the face, and 
masking is the process of concealing or covering. The subtopics include types of masks 
and associated words, such as "mystery." Each member of the group is given the 
assignment to create a visual that illustrates the definition of the word to present at the 
next meeting.  

As you leave the meeting, you start thinking of several ideas. You decide to create your 
mask presentation in Adobe Photoshop and title it "The Mystery of Masks." You plan to 
make photographic images of different types of masks to use as examples to explain the 
complex concept.  

This lesson will follow a similar approach as you learn to unravel the mystery of 
Photoshop layer masks. However, before you start exploring masks, you'll need a good 
foundation in selection methods, painting with brushes, and the ability to work with 
layers. You may find it helpful as you go through this lesson to review the sections in 
Photoshop Help on selections, brushes, and layers.  

Overview of masks  
Figure 3-1 shows some examples of different types of masks. The first face is just a plain 
face without a mask. The second face, B, has safety glasses to protect the eyes. The third 
face, C, has eyeshades to conceal the eyes, and the fourth face, D, has a typical costume 
mask that partially conceals the face.  

 



 
Figure 3-1: Mask faces.  

The definition and illustration of the different types of masks relate to Photoshop in 
several ways. First, you use a mask in Photoshop to protect one area of an image to edit 
another part. Second, you use a mask to conceal or hide areas from view. These uses 
relate to the two main functions of Photoshop: image editing and image creation.  

The main types of masks in Photoshop are selection masks and layer masks. You learned 
about selection masks (quick mask and alpha channel masks) in Lesson 1 of this course.  

Let's briefly review the introduction to masks from Lesson 1. In the context of 
Photoshop, a mask is a grayscale representation of an image with an active selection. A 
selection is the way to separate or isolate parts of the image. In Lesson 1, you made a 
selection of a leaf to isolate it from the background and used Quick Mask mode as a 
temporary mask to fine-tune the selection. You learned how to edit in the mask by 
painting with black, white, or shades of gray to either conceal or reveal parts of the mask.  

You also learned in Lesson 1 how to save a selection as an alpha channel mask and to 
edit the mask with the same painting technique.  

The saying that "black hides and white reveals, and gray partially reveals" is a basic 
concept of all masks, and will be repeated in this lesson.  

For a selection, the moving dashed line (marching ants) is the visual indicator that shows 
the separation of the parts of the image. The area outside the marching ants is the 
protected area and the inside area is unprotected. A selection allows you to concentrate 
on the inside area. You can inverse the selection to select the opposite part of the image. 



You can also smooth the area between the inside area and the protected area of the 
selection with feathering. The grayscale representation of the selection with the image is 
not visible until you save the selection, which converts it to a mask.  

For a mask, the protected area is indicated with either a red color (rubylith) or black. The 
unprotected area is clear or white. You can also inverse the mask. You use the Gaussian 
Blur filter in a mask to smooth the transition between the protected and unprotected areas 
of the image. With a mask, you're working with the grayscale representation of the image 
and can edit it by painting with black, white, or shades of gray.  

When you're working with selections and masks in a complex image -- one with many 
separate images and elements -- you'll use layers to organize and keep track of every part 
of the image. Layers also give you the flexibility to try many variations of designs and 
color adjustments that remain editable until you flatten or merge the layers. You can keep 
each element on a separate layer and hide and show a layer.  

One of the most important ability of layers is transparency. The entire layer or a portion 
of the layer that is transparent (without pixels or pixels hidden from view) reveals the 
layer below. For example, in Figure 3-1, the first face, A, without any mask represents an 
image on a layer. The safety glasses in the second face, B, represent a transparent layer. 
In this general view, a layer without pixels except for the background layer is a 
transparency mask. The masks for faces C and D that hide or partially reveal the face 
represent a layer mask.  

Use layer masks 
Layer masks are simply masks that are associated with a layer. Layer masks can take 
advantage of many of the same functions and flexibility of regular layers. With the power 
of mask painting and editing combined with the flexibility of layers, your creativity and 
imagination can take your images even further than you can possibly dream.  

A layer mask is associated with regular layers and special types of layers. In Lesson 2, 
when you created an adjustment layer, a layer mask was automatically added with the 
layer. Figure 3-2 identifies the Levels adjustment thumbnail and the layer mask 
thumbnail in the Layers palette.  



 
Figure 3-2: Levels adjustment layer with associated layer mask.  

Photoshop automatically adds layer masks with the following types of layers when you 
use the Paste Into command: New fill or adjustment layer and vectors. Vector masks are 
beyond the scope of this lesson. You can add a layer mask to other layers except for the 
background and type layers.  

Let's start the exploration of layer masks with a simple single image file and learn how to 
add a layer mask. You can save the provided OldMissionChurch.jpg file to your 
computer or use one of your own image files. First, you'll do some basic layer practice. 
Second, you'll add a layer mask.  

To practice with layers and add a layer mask, do the following:  

1. Open the OldMissionChurch.jpg file, make a duplicate, and then save it as 
Practice_layermask1.psd. Close the original file.  

2. Double-click the Background layer in the Layers palette. In the New Layer dialog 
box, rename the layer Old Mission, and then click OK.  

3. Ctrl+click the Create a new layer button in the Layers palette to create a new layer 
below the current Old Mission layer. Name the new layer Pattern.  

4. Hide the Old Mission layer to make it easier to see the pattern you'll add in the 
next step.  

5. Select the Paint Bucket tool (G) in the toolbox. It's grouped with the Gradient 
tool.  

6. On the options bar, select Pattern from the first drop-down menu on the left. 
Select a grayscale pattern, such as Gauze or Granite, from the second menu. This 
serves as a visual aid to make it easier to see what's hidden and what's revealed.  

7. Click inside the canvas area with the Paint Bucket to fill with the pattern.  
8. Click the visibility icon (eye) in the Layers palette to show the Old Mission layer, 

and then click the layer to activate it. The entire image of this layer is selected 
even without seeing the selection marquee. To display the selection marquee, 
Ctrl+click the layer thumbnail.  



The ability to Ctrl+click to load a selection in a layer is a new change in Photoshop CS2. 
In previous versions, you could click anywhere in the layer.  

9. Press Ctrl+D to unselect the layer.  
10. Select the Rectangular Marquee tool (M), and then draw a selection anywhere on 

the image. For example, you can draw a selection around the church.  
11. Press Backspace to delete the pixels and reveal the layer below containing the 

pattern.  
12. Press Ctrl+Z to undo the change, and then press Ctrl+D to unselect.  
13. With the Old Mission layer still selected, select Layer > Layer Mask > Reveal 

All, or click the Add layer mask button in the Layers palette.  

Photoshop adds a white layer mask that reveals all of the pixels. While you're learning 
about layer masks, it's a good idea to use the menu item to add a layer mask because the 
name of the command helps you to learn the difference between hide and reveal. Your 
Layers palette should look similar to Figure 3-3.  

 
Figure 3-3: Layer mask in Layers palette.  

The Layers palette in Photoshop CS2 looks different than in previous versions. Adobe 
removed the second column with the active icons, and moved the link icon to the bottom 
of the palette.  

14. With the layer mask active -- indicated by the extra line around the thumbnail -- 
draw a rectangular marquee around the church.  

15. Press Backspace to delete. In the layer mask, the pixels are hidden from view 
revealing the pattern on the layer below. In the layer mask thumbnail, you see the 
black rectangle (hidden area), as shown in Figure 3-4.  



 
Figure 3-4: Layer mask with masked selection in Layers palette.  

16. Alt+click inside the layer mask thumbnail to view the layer mask in the active 
window. Alt+click again to return to the previous view.  

17. Select the Channels tab in the Layers group, or select Window > Channels, to 
open the Channels palette. The layer mask is added to the bottom of the Channels 
palette. To save your layer mask as an alpha channel, load the selection for the 
layer and then click the Save selection as channel button in the Channels palette.  

18. Return to the Layers palette. To see the display of the mask with the red mask 
color, Shift+Alt+click inside the layer mask thumbnail or press the backslash key. 
To return to the previous view, press the key sequence again.  

19. Shift+clickinside the layer mask thumbnail to disable or turn off the layer mask. 
Click inside the layer mask icon to turn on the layer.  

20. Click the mask link icon between the two thumbnails to unlink the layer mask.  
21. Click the selection in the image to unselect it. Select the Move tool (V), and then 

click inside the mask to move the current masked area anywhere on the image. 
You can turn off the Pattern layer to see that the masked area is in a new location. 
To link the layer mask back to the associated layer, click the area between the two 
thumbnails.  

22. Drag the layer mask thumbnail to the Delete layer icon at the bottom of the 
Layers palette, or right-click and select Delete Layer Mask from the shortcut 
menu. A warning dialog box appears, as shown in Figure 3-5. This allows you to 
apply the mask before you delete the layer mask. Applying the mask is similar to 
merging a layer. For this example, click Delete.  

 
Figure 3-5: Delete layer mask warning.  



To delete the layer and the associated layer mask, drag the layer thumbnail to the Delete 
layer icon. For this example, do not delete the layer.  

23. Make sure you have only the two layers without any layer masks. Select Layer > 
Layer Mask > Hide All, or Alt+click the Add layer mask button in the Layers 
palette. Photoshop adds a layer mask with the entire area filled with black 
indicating that all the pixels (transparent) are hidden and it reveals the pattern 
layer below, as shown in Figure 3-6.  

 
Figure 3-6: Layer mask hide all.  



 

24. Delete the layer mask.  

Now you'll create a layer mask based on a selection, as follows:  

1. In Practice_layermask1.psd, select the sky with the Magic Wand tool.  
2. On the options bar, change the Tolerance setting to 50.  
3. Select the sky with the Magic Wand tool again. Shift+click to add to the selection. 

For this exercise, the sky doesn't have to show through the tree.  
4. Select Layer > Layer Mask > Reveal Selection, or click the Add layer mask 

button in the Layers palette.  

The layer mask based on the sky selection is masking the bottom half of the image, which 
is the area outside the selection. The results are the same as making a mask in Quick 
Mask mode or saving the selection as an alpha channel, except that the mask is in a 
separate layer mask associated with the layer.  

Because this is a layer mask, in addition to protecting the area outside of the selection, the 
black masked area is hiding the pixels and utilizing the transparency function of the layer. 



This additional function of layer masks gives you a wide range of possible effects and the 
layer masks are editable until you apply the layer mask to the layer.  

Paint in a layer mask 
Now it's time to repeat the saying "Black hides and white reveals." You can paint with 
black in a white area of the mask to hide or subtract additional pixels. When you paint 
with gray, you partially hide more pixels. Painting with white in a black area adds or 
reveals more pixels.  

Let's paint in the layer mask. As you're learning this new process, you'll find it helpful to 
create a duplicate window of your image to see both the image layer and the layer mask 
as you paint.  

To paint in the layer mask, do the following:  

1. Select Window > Arrange > New window for<file name of open image>.  
2. Press Ctrl+D to unselect the selection, if necessary.  
3. Alt+click inside the layer mask thumbnail to edit the mask.  
4. Select the Brush tool. The default brush is acceptable for this example. To set the 

tool back to its defaults, right-click the icon of the brush on the options bar.  
5. Paint with white in the area of the tree on the right side of the image, as shown in 

Figure 3-7.  

 
Figure 3-7: Painting with white in the layer mask.  

»Enlarge image  



6. Press X to switch the foreground color to black, and then paint the narrow white 
area on the left side of the image to add these pixels to the mask area, which 
makes them transparent.  

7. Press X to switch the foreground color to white. With the Rectangular Marquee 
tool, draw a narrow rectangle near the bottom of the image. Use the Brush tool to 
paint with white inside the selection in the mask. This reveals a narrow strip of 
grass in the image, which you can view by selecting the Pattern layer in the 
Layers palette.  

8. Press Ctrl+D to unselect the rectangle in the layer mask.  
9. Alt+click inside the layer mask thumbnail to edit the mask.  
10. Draw another rectangular selection area approximately in the middle of the black 

masked area. Open the Color palette and move the slider to the middle to change 
the foreground color to gray or type in a percentage of gray. Alternatively, you 
can reduce the opacity of the Brush tool. Paint inside the rectangle with gray. This 
partially reveals the image, as shown in Figure 3-8.  

 
Figure 3-8: Painting with gray in the layer mask.  

11. Unselect the rectangle, and then delete the layer mask.  

Next, base the layer mask on the sky selection to hide it, and then make a gradient in the 
bottom half of the image to gradually paint in the image, as follows:  

1. Use the Magic Wand tool to select the sky again. As before, the selection doesn't 
have to be perfect for this example.  

2. Select Layer > Layer Mask > Hide Selection.  
3. Alt+click the layer mask thumbnail to see the mask. The lower half of the image 

is now revealed and the sky area is masked, as shown in Figure 3-9.  



 
Figure 3-9: Layer mask hide selection.  

4. Ctrl+click the layer mask icon to load the revealed selection. This is an important 
step. If you don't load the selection in the mask, the gradient covers the entire 
image.  

5. Press D to set the foreground and background colors to the defaults and, if 
necessary, press X to set the foreground color to black.  

6. Select the Gradient tool, and then set the Gradient type to Foreground to 
Background.  

7. Start at the bottom of the white area, approximately in the middle, and then drag 
upward with the Gradient tool. Remember that black is hiding or making the 
pixels transparent, gray is partially hiding and white reveals.  

While still in the layer mask, apply the Gaussian Blur filter to soften the transition 
between the two areas of the image. Select Filter > Blur > Gaussian Blur. In the Gaussian 
Blur dialog box, move the slider all the way to the left, and then start increasing until you 
have just enough transition between the black-and-white areas, as shown in Figure 3-10. 
This is a visual adjustment so yours may be different. Click OK.  



 
Figure 3-10: Gaussian Blur dialog box.  

You can experiment more with this image, and then save the practice file if you want. 
Figure 3-11 shows how a quick change to a different pattern and a tree touch-up gives 
creates a dramatically different image. The great thing about layer masks is that you can 
disable, delete, edit later, or apply the changes to the layer.  

 
Figure 3-11: A new image using layer masks.  

Create special effects for vignettes 
Let's use some of the layer mask basic techniques to create some special effects for 
vignettes. For the first vignette, you'll create a soft light focus on the main subject of the 
black-and-white image. You'll make a selection for the center focus, create a blank layer, 
make a layer mask based on the Hide selection to protect the center focus of the image, 
fill the new layer with black, reduce the layer opacity, and then add the Gaussian Blur 
filter.  



To create special effects, do the following:  

1. Open the YuccaPlant.jpg file, make a duplicate file, and save it as Vignette1.psd. 
Close the original file.  

2. Press D to reset the foreground and background colors.  
3. Select the Elliptical Marquee tool (M), and then draw an ellipse around the center 

yucca plant. Press Alt to draw from the center outward and use the spacebar to 
move the ellipse as you draw. Be sure to release the mouse first.  

4. Click the Create a new layer button in the Layers palette and rename the layer 
Center Focus. A new layer with no pixels is created.  

5. Alt+click the Add layer mask button in the Layers palette. A layer mask that hides 
and protects the selection indicated by the black masking color is created. 
Because the associated Center Focus layer does not have any content, you don't 
see visible changes in the image.  

6. Click the Center Focus layer thumbnail to activate the new layer, and then press 
Alt+Backspace to fill it with black, as shown in Figure 3-12.  

 
Figure 3-12: Layer filled with black.  

7. Lower the opacity of the layer to approximately 46%.  
8. Click the layer mask thumbnail to make it active, and then select Filter > Blur > 

Gaussian Blur. The Gaussian Blur dialog box appears.  
9. Move the slider all the way to the left and then gradually move the slider to the 

right to produce the desired soft light. Watch both your image and the preview in 
the Gaussian Blur dialog box to see the effect, as shown in Figure 3-13.  



 
Figure 3-13: Add the Gaussian Blur effect.  

Click inside the Radius text box, and then use the up and down arrow keys to increase the 
decimal point column by one. Press Shift+up arrow to increase the whole number by 1.  

10. Click OK. When you're satisfied with the image, save the changes and close the 
file.  

For the second vignette, the main area of interest will remain in focus and you'll blur the 
background. You'll use another layer mask to accomplish this.  

To create special effects in the second vignette, do the following:  

1. Open the RoadsideWildflowers.jpg file, make a duplicate, and save it as 
Vignette2.psd. Close the original file.  

2. Select Layer > New > Layer via Copy, or press Ctrl+J, twice to make two 
duplicate copies of the Background layer.  

3. Rename the top layer Focus area, and then rename the middle layer Blur.  
4. Hide the Focus area layer by clicking the visibility icon.  
5. Activate the Blur layer.  
6. Select Filter > Blur > Gaussian Blur, and then apply a blur of approximately 7. 

The image should be very blurry, as shown in Figure 3-14.  



 
Figure 3-14: Extreme blur.  

7. Turn on the Focus area top layer to make it the active layer.  
8. Select the Elliptical Marquee tool (M), and then draw an ellipse around the three 

large flowers in the foreground.  
9. Select Select > Feather, and then enter a desired feather amount (for example, 20) 

to soften the selection. You can use the Feather command instead of the Gaussian 
Blur because you're working in the selection on the layer and not in a layer mask.  

10. Click the Add layer mask button at the bottom of the Layers palette. Keep the file 
open.  

Based on your knowledge about layer masks, can you explain the last step? First, disable 
the mask (Shift+click the layer mask thumbnail). You should see that the sharp image is 
covering the layer below it, which is blurry. Click inside the layer mask thumbnail to 
enable the layer mask. The selection oval white area of the layer mask reveals the clear 
sharp area of the associated layer. The black or masked area outside the ellipse hides or 
makes the pixels transparent to see the blurry layer below.  

Before you close this file, boost the color of the flowers with an adjustment layer. An 
adjustment layer affects all layers below it. To contain the effect to just the top layer, you 
can create a clipping mask.  

To create a clipping mask, do the following:  

1. In Vignette2.psd, activate the Focus area layer.  
2. Click the Create a new fill or adjustment layer button in the Layers palette, and 

then select Channel Mixer.  



3. Move the Red source channel slider to the right to approximately 152, which adds 
more color to the flowers and to the rest of the image. Click OK. As you can see 
in Figure 3-15, the new color adjustment applies to all the layers below it. 
Although this may create an artistic image, the desired result is to just add color to 
the main flowers in the vignette.  

 
Figure 3-15: Color affects all the layers of the image.  

4. To create the clipping mask for the layers, press Alt and move the mouse to the 
line that separates the adjustment layer and the layer below it until you see the 
small double circle, as shown in Figure 3-16.  

 
Figure 3-16: Layer clipping mask.  

Now the Channel Mixer adjustment affects only the layer directly below it, as shown in 
Figure 3-17.  



 
Figure 3-17: Layers palette with layer clipping mask.  

In this situation, you can also solve the problem using the layer mask, as follows:  

1. To release the clipping mask, press Alt and move the mouse between the lines 
separating the layers until you see the overlapping circles appear. Click to release 
the layer.  

2. Delete the Channel Mixer adjustment layer and its associated layer mask by 
dragging the adjustment layer thumbnail to the Delete icon at the bottom of the 
Layers palette.  

3. Ctrl+click the layer mask thumbnail in the Focus area layer, which activates the 
selection.  

4. Click the Create a new fill or adjustment layer icon on the Layers palette, and then 
select Channel Mixer.  

5. Move the Red source channel slider to approximately 144, and then click OK.  
6. Click the layer mask thumbnail in the adjustment layer (the top one) and paint 

with black to restore some of the original color around the flowers.  
7. Save the changes and close the file.  



Create a simple composite image with layer masks 
In the last section of this lesson, you'll use two images and layer masks to create a simple 
composite image. You'll also add a filter.  

To create the composite image, do the following:  

1. Open the WhiteFlowers.jpg file and, if necessary, select an appropriate color 
profile. Make a duplicate of the file, and then save it as Composite1.psd. This 
image will serve as the background of the composite image.  

2. Open the OldBuilding.jpg file and, if necessary, select an appropriate color 
profile. Select Select > All, or press Ctrl+A.  

3. Select the Move tool (V) from the toolbox, press Shift, and then drag the old 
building image on top of the white flowers. Pressing Shift drops the image into 
the exact middle of the canvas. The building image is now on a separate layer and 
it completely covers the flowers.  

4. Close the OldBuilding.jpg file.  
5. Rename Layer 1 Building.  
6. To give the building a hand-drawn look, apply a filter. Select Filter > Stylize > 

Find Edges.  
7. Click the Add layer mask button at the bottom of the Layers palette, or select 

Layer > Layer Mask > Reveal All. If you reduce the opacity of the building layer 
to approximately 75%, you can see some of the flowers on the layer below. The 
reduced opacity of the layer enables you see where to paint.  

8. Make sure that the layer mask is active and the default foreground and 
background colors are set to black and white, respectively.  

9. Select the Brush tool, select an appropriate size brush and style, and then paint 
over parts of the building with black to make the pixels on the top layer 
transparent, as shown in Figure 3-18.  



 
Figure 3-18: Painting with black in the layer mask.  

10. Switch to white (press X) to repaint any of the building image back into the 
picture.  

11. Continue painting, filtering, and transforming your image. You can add extra 
canvas and type at the bottom. Figure 3-19 shows one possible composite image.  



 
Figure 3-19: Composite image.  

12. Save Composite1.psd and close all files.  

You're now ready to let your imagination and the power of Photoshop take you on an 
incredible journey into imaging masking and compositing.  

 


